[Glass] [] WAGemStoneRunSmalltalkServer

Dale K. Henrichs dale.henrichs at gemtalksystems.com
Fri Aug 9 10:20:36 PDT 2013


To debug the setup, you should run:

  WAGemStoneRunSmalltalkServer startGemServer: '<servername>" On: <port number>.

in your GemTools image. Be aware that the above statement will block until you hit an error of some sort and you need to read the section on GemTools and processes[1] and some tips on working with servers[2]. For debugging out of memory problems, read the post on that topic[3].

If you do the above, the GemTools debugger will come up when you hit a problem either out of memory or an error ... doing the above you can set breakpoints or halts and the debugger will come up and you can track things down using normal development techniques ...

Once you get to the point where the server starts and runs normally, you will need to install some strategically placed error handlers so that you can arrange to snap off continuations and stash them in the Object Log for later debugging ... this is already done for you in Seaside...


[1] http://gemstonesoup.wordpress.com/2009/04/15/glass-beta-update-working-with-soap-preview/#GsProcesses
[2] http://gemstonesoup.wordpress.com/2009/04/15/glass-beta-update-working-with-soap-preview/#soaphttpdev
[3] http://gemstonesoup.wordpress.com/2008/11/19/gemstone-101-managing-out-of-memory-situations/
----- Original Message -----
| From: "Sebastian Heidbrink" <sebastian_heidbrink at yahoo.de>
| To: glass at lists.gemtalksystems.com
| Sent: Friday, August 9, 2013 8:51:17 AM
| Subject: Re: [Glass] [] WAGemStoneRunSmalltalkServer
| Hi Dale,
| I tried it and I get the same result....
| Meanwhile I realized that my script only works if I commit my
| transaction prior to starting the gem like this:
| "
| WAGemStoneRunSmalltalkServer addServerOfClass: ZnServer withName:
| 'myserver' on: #(9001).
| .... commit the transaction ...
| WAGemStoneRunSmalltalkServer startGems: (WAGemStoneRunSmalltalkServer
| serverNamed: 'myserver').
| "
| Otherwise the (WAGemStoneRunSmalltalkServer  serverNamed: 'myserver')
| is
| nil in WAGemStoneRunSmalltalkServer startServer: serverName On:
| portInteger.
| Since the remote debugging does not work with the currently delivered
| runSmalltalkerver scriptsfor I have to work with "halt" and
| looking into the logs.
| I already tried to change the script this way: see attached
| It seems the listenloop is running, but I never end up in
| "handleRequest" :-/
| Sebastian
| _______________________________________________
| Glass mailing list
| Glass at lists.gemtalksystems.com
| http://lists.gemtalksystems.com/mailman/listinfo/glass

More information about the Glass mailing list