[Glass] Debugging an app with Jade

Sebastian Heidbrink sebastian_heidbrink at yahoo.de
Thu Dec 26 08:06:31 PST 2013

I sometimes open a Gemtools image and start my server there.
If the debugger shows up, I debug change my code in Jade commit the 
stuff and restart the Gemtools server if needed.

Debugging simply doesn't work as well as in other Smalltalk 
applications. If you are able to commit a change from within a Debugger, 
then you are lucky. If the server process resumes from within a Debugger 
you are lucky too.

I wonder if I will loose too much productivity once the workflow, to 
reach the current spots of development, becomes to long.

I can remember that I once was able to work from within one dev 
environment and do debugging and develoment at a time,... but I have no 
idea how I did this, or if there's just something broken now.

Using the object log is also a good idea, but you are mssing the current 
values of certain needed variables most of the time and that becomes 
tricky once you analize an error within a loop.

Merry Christmas!

Am 26.12.2013 07:08, schrieb James Foster:
> Lyn,
> Although I use Jade I haven't tried to debug a FastCGI process 
> directly. Instead I use the debugger to view the stack saved to the 
> object log. There is a menu command on the Transcript window and a 
> shortcut (<Ctrl>+L I think).
> James
> Sent from my iPhone
> On Dec 26, 2013, at 5:56 AM, Lyn Headley <laheadle at gmail.com 
> <mailto:laheadle at gmail.com>> wrote:
>> Perhaps I spoke too soon, as I have still not figured out how to best 
>> debug my error. I am now able to launch gems from my jade environment 
>> but am not sure how to open a debugger or otherwise find out the 
>> source of the error message which I reported in the opening post of 
>> this thread. Although I can access the Transcript window, I don't see 
>> a Debug button.
>> On Thu, Dec 26, 2013 at 9:42 AM, Lyn Headley <laheadle at gmail.com 
>> <mailto:laheadle at gmail.com>> wrote:
>>     Thanks to Sebastian Heidbrink for helping me get this working.
>>     The problem was that I was not committing my transaction with my
>>     configuration changes before running the startGems method, so a
>>     new gem was launched which did not recognize my preferred
>>     configuration, and therefore started a FastCGI process (the
>>     default) rather than a Swazoo process.
>>     On Sat, Dec 14, 2013 at 7:05 AM, Lyn Headley <laheadle at gmail.com
>>     <mailto:laheadle at gmail.com>> wrote:
>>         I got a helpful hint from Sebastian Heidbrink, which led me
>>         to discover the ControllingSeaside30Gems wiki page. However,
>>         I only seem to be able to launch fastcgi gems when I want to
>>         launch Swazoo gems. If I evaluate the following:
>>         "Specify Swazoo for runSeasideGems30 and start 1 vm listening
>>         on port 8383"
>>         WAGemStoneRunSeasideGems default
>>                 name: 'Swazoo';
>>                 adaptorClass: WAGsSwazooAdaptor;
>>                 ports: #(8383).
>>         WAGemStoneRunSeasideGems startGems. "start gems"
>>         I can see a couple of topaz processes running:
>>         laheadle  3192  0.0  1.2 210664  6028 ?        S    05:56  
>>         0:00 /opt/gemstone/product/bin/topaz -l -e
>>         /opt/gemstone/product/seaside/etc/seaside30.conf
>>         laheadle  3194  0.0  1.7 692900  8900 ?        S    05:56  
>>         0:00 /opt/gemstone/product/bin/topaz -l -e
>>         /opt/gemstone/product/seaside/etc/maintenance30.conf
>>         So far, so good. But I can't load http://myhost:8383 in my
>>         web browser, and when I telnet to port 8383, I am told:
>>         0Incorrect FCGI version. Expected: 1 Received: 71Connection
>>         closed by foreign host.
>>         On Fri, Dec 13, 2013 at 11:32 PM, Lyn Headley
>>         <laheadle at gmail.com <mailto:laheadle at gmail.com>> wrote:
>>             Hello GLASS!
>>             I am currently porting a seaside app from pharo to
>>             Gemstone/S, developing using Jade, and am trying to
>>             figure out how to get a debugger on an error message. I
>>             can launch my seaside application by executing the
>>             following in a Jade workspace:
>>             WAGsSwazooAdaptor new start.
>>             This never returns, makes the workspace unusable, and
>>             opens a modal window that says Executing
>>             Gemstone/Smalltalk code... and offers two buttons: Hard
>>             Break and Soft Break.
>>             When I load my seaside application by visiting the
>>             application entry point in a browser, I get the error
>>             below. I'm wondering what the best way to debug the error
>>             is, ideally I'd like to call up a debugger on my code.
>>              I'm also interested in looking at the "continuation
>>             containing error stack" if that would be helpful.
>>             Although the error page says: "To bring up a debugger in
>>             your development image, press the Debug button in the
>>             GemStone/S Transcript window," I can't access the
>>             Gemstone/S Transcript because the workspace is
>>             inaccessible due to the modal window.
>>             Here is the error:
>>             a LookupError occurred (error 2053), The instance
>>             variable #'footer' was not found in evaluating a path
>>             expression for the object aLHHeader.
>>             Error during rendering, a continuation containing error
>>             stack has been saved
>>             To bring up a debugger in your development image, press
>>             the Debug button in the GemStone/S Transcript window.
>>             For the moment, resuming from a remote debug session is
>>             not supported
>> _______________________________________________
>> Glass mailing list
>> Glass at lists.gemtalksystems.com <mailto:Glass at lists.gemtalksystems.com>
>> http://lists.gemtalksystems.com/mailman/listinfo/glass
> _______________________________________________
> Glass mailing list
> Glass at lists.gemtalksystems.com
> http://lists.gemtalksystems.com/mailman/listinfo/glass

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gemtalksystems.com/mailman/private/glass/attachments/20131226/609075f9/attachment.html>

More information about the Glass mailing list