[Glass] sources of idle time when running tests?

Paul DeBruicker pdebruic at gmail.com
Tue Sep 17 13:50:52 PDT 2013


In Gemstone + GLASS 1.0b91 +GemTools 1.0b71 all on my local
machine I'm running some tests in my app and when run they take 1000x
longer than in Pharo.  I'm not sure why and it seems to be related to my
code and not the system at large as tests from other test suites seem
normal speed.

If I run a test like

[MyTests run: #testSimple] timeToRun

it prints in the neighborhood of around 33,000ms but the CPU is idling
most of that time.

If I run the test with the ProfMonitor

ProfMonitor monitorBlock:[MyTests run: #testSimple]

it shows a run time of 232 ms, but also takes about a half minute.  If I
put the ProfMonitor send in a timeToRun block then I get a run time
thats around 33,000ms as well.

What should I look at to attempt to diagnose what is going on?

The same slowness is evident if running the tests through TestRunner.



More information about the Glass mailing list