[Glass] Very strange error - one method can not be found ...

itlists@schrievkrom.de via Glass glass at lists.gemtalksystems.com
Wed Oct 15 09:23:23 PDT 2014

* the method is there. I saw it and all code worked in a workspace in
Jade without any problems - and recompiling all methods solved the
problems. The structure of the class A has not changed and is pretty old
and was not updated and other methods of this class worked without
problems. I see no class versions or stuff like this.

Actually I had/have no idea what went wrong. I just wanted to mention it.


Am 15.10.2014 um 16:02 schrieb James Foster:
> My suspicion is that the compiled method referred to a class A that did not have method #’x:’. How could that happen? If you had a class A but removed it and created a new A, then the compiled method would still refer to the removed class. Recompiling the method did the lookup over again and found the new A.
> James
> On Oct 15, 2014, at 4:15 AM, itlists at schrievkrom.de via Glass <glass at lists.gemtalksystems.com> wrote:
>> Today I had a very strange error in one of our development platforms:
>> Assume a class named "A" containing an instance method: "x:".
>> In lots of methods I create instances of class "A" and set the attribute
>> values via "x:" like:
>>  ^A new initialize
>>    ... ;
>>    x: aValue ;
>>    ...;
>>    yourself
>> And ALL methods calling "x:" are now not working any more. Gemstone
>> tells me, that x: can not be found. Executing the code in a workspace
>> works without problems.
>> To get rid of this error I enter the source code, add a space, recompile
>> the method and now "x:" can be called without problems.
>> Marten
>> -- 
>> Marten Feldtmann
>> _______________________________________________
>> Glass mailing list
>> Glass at lists.gemtalksystems.com
>> http://lists.gemtalksystems.com/mailman/listinfo/glass

Marten Feldtmann

More information about the Glass mailing list