[Glass] Short introduction with tODE, Git, packages and so on ...

Dale Henrichs via Glass glass at lists.gemtalksystems.com
Sat May 21 12:37:30 PDT 2016

Hmmm ... I'n still not able to reproduce the problem, but it sounds like 
it is probably related to the the MNU associated with the 'create new 
packages' issue[1], so perhaps you can retest once I've fixed the bug?


[1] https://github.com/dalehenrich/tode/issues/259

On 5/21/16 9:03 AM, Marten Feldtmann wrote:
> From "tools>Packages [mc]" I got a window named "Working copies (2)" 
> and from there I select "create new packages" and enter a named and I 
> get an AlmostOutOfStack error in IdentityDictionary>>at:ifAbsent: 
> within a process where STON091Writer tries to write  stuff  (whatever 
> that may be - here I use Gemstone/S 3.2.14)
>>> First a bug:
>>> *Creating a new package*
>>> From the pop-up menu, open "Packages (mc)" and one gets all known 
>>> packages - adding a new packages results into a StackOverflow error. 
>>> Hmm.
>> I assume that this is the 'Tools > Packages [mc]' menu? I am not able 
>> to get a stack overflow :(
>> I tried this with 3.2.12 and 3.3.0, so perhaps some detail on the 
>> version of GemStone that you are using? Plus I am curious as to the 
>> versions of the projects that you are using. If you use the 'Window > 
>> print window' menu on an open project list, I will get just about all 
>> the information I need to reproduce your problem.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gemtalksystems.com/mailman/private/glass/attachments/20160521/53b68beb/attachment.html>

More information about the Glass mailing list