[Glass] Issue #260: eliminate reliance on 32 bit devKitCommanLine image -- call for volunteers

Dale Henrichs dale.henrichs at gemtalksystems.com
Mon Nov 4 09:59:21 PST 2019

On 11/1/19 3:50 PM, BrunoBB via Glass wrote:
> Dale,
> Tracking the errors (at least in my installation) and it seems that
> $ROWAN_PROJECTS_HOME is not defined.

ROWAN_PROJECTS_HOME is supposed to be added to the custom_stone.env file 
in the install_launcher.st script[1], called on this line[2] in the 
bootstrap_launcher script -- there is stop/start netldi following that 
to ensure that ROWAN_PROJECTS_HOME gets set for all topaz sessions 
launched against that stone ...

Could you have somehow bypassed that step?

I think that if you want to install in a freshly cloned GsDevKit_home 
instance, you should just skip the initial `updateGsDevKit -gdtcs` and 
then you'd be fine after that ...

I ran my tests in a separate GsDevKit_home instance (not freshly cloned, 
so the devKitCommandLine image had already been defined ... just 
invoking `devKitCommandLine` in a fresh clone, should build the 
devKitCommandLine image) and every time I ran into an error I would 
checkout the master version delete the shared/gemstone directory, fix my 
scripts (in another close) push to issue_260 and then do a fresh 
checkout and pull and then run the scripts from the beginning ...

You should not have to edit scripts and hardcode paths...

> Because i change that variable in some scripts with hardcoded path and i was
> able to go further but eventually failed at:
> /home/gemstone/GsDevKit_home/shared/repos/GsDevKit_launcher/bootstrapping/gemstone/bin/bootstrap_install_tode.tpz
> Because /usr/local/bin/smalltalk/gemstone/topaz does not exist, the actual
> error:
> /home/gemstone/GsDevKit_home/shared/repos/GsDevKit_launcher/bootstrapping/gemstone/gsdevkit_home/newBuild_SystemUser_gsdevkit_launcher_tode:
> /home/gemstone/GsDevKit_home/shared/repos/GsDevKit_launcher/bootstrapping/gemstone/bin/bootstrap_install_tode.tpz:
> /usr/local/bin/smalltalk/gemstone/topaz: bad interpreter: No such file or
> directory

This error is also a result of not running the install_launcher.st 
script[1] ... you are missing symbolic links that are created here[3].

Perhaps you should try to install in a fresh clone and skip the 
`updateGsDevKit -gdtcs` step?



> Maybe i'm doing something wrong i will check again later ...
> regards,
> bruno
> --
> Sent from: http://forum.world.st/GLASS-f1460844.html
> _______________________________________________
> Glass mailing list
> Glass at lists.gemtalksystems.com
> https://lists.gemtalksystems.com/mailman/listinfo/glass

More information about the Glass mailing list