[Glass] installation fails on Ubuntu 20.04 because of outdated libssl

Dale Henrichs dale.henrichs at gemtalksystems.com
Wed May 26 10:22:22 PDT 2021


[sorry for the late reply, but my mail client didn't send this message when I wrote it a week ago, and I didn't notice until now]
This seems to be in intermittent error on 20.04. It was originally reported last July [1], but I was not able to reproduce the failure[2], as the gsDevKitCommandLine.image was created without error ... The original reporter (Marten Feldtmann) reinstalled GsDevKit_home and tried again and was successful[3].
The issue is appearing in 32 bit Pharo3.0 and the missing libssl1.0.0:i386 file does not appear to be the cause of the problem, so I'm not sure if there is very much that can be done to resolve the root problem other than replace Pharo3.0 with a 64 bit solution.
The good news (I suppose) is that back in the March/April timeframe Jupiter Jones and I revived work on issue #260 [4](replacing use 32 bit pharo with topaz solo scripts).
Issue #260 was first opened in October of 2019 and I sent out a call for volunteers[5] at that time which did not garner much support (thank you Bruno for stepping up to the plate at that point in time).
This time around we are using a different solo scripting project, superDoit[6] which is a scripting solution that is specific to GemStone. The scripts include support for help and argument handling and here is a simple example of a script with help and command line arguments[7]. To date, Jupiter has replaced a handful of the $GS_HOME scripts with superDoit .solo scripts, but there is more work to be done. Johan Brichau has also indicated that he is planning to contribute.
None of us has a lot of free time to devote to the conversion project, but it is something that is well overdue. There are around 100 bash scripts that need to be rewritten so if anyone else has some spare time to contribute your help will be appreciated!
Some of the bash scripts are all in bash and should be straight forwrd to translate into smalltalk Some of them make calls to Pharo3.0 and and will be a bit more complicated, since the Pharo code will have to be ported to the solo script. Jupiter has already ported some of the Pharo code to GemStone and that work has been done by creating classes in filetree packages that are loaded into the solo extent when the script is executed.
Part of this project also involves creating a new version of GsDevKit_home and Jupiter has a plan that allows the new version of GsDevKit_home to be used against an existing GsDevKit_home installation or "attached" to non-GsDevKit_home stones as well ... basically the stone meta-data is stored in a directory structure totally independent of the stones directory structure so if all goes well the new version of GsDevKit_home will be useful in a wider range of installations ...
If you are interested in contributing, send me an email and I'll add you to an internal slack channel that is devoted to this project where we'll share additional details and coordinate the work.
[1] https://github.com/GsDevKit/GsDevKit_home/issues/291
[2] https://github.com/GsDevKit/GsDevKit_home/issues/291#issuecomment-673053921
[3] https://github.com/GsDevKit/GsDevKit_home/issues/291#issuecomment-678983033
[4] https://github.com/GsDevKit/GsDevKit_home/issues/260
[5] http://forum.world.st/Issue-260-eliminate-reliance-on-32-bit-devKitCommanLine-image-call-for-volunteers-tp5105781p5106478.html
[6] https://github.com/dalehenrich/superDoit
[7] https://github.com/dalehenrich/superDoit/blob/master/examples/simple/simpleArgs.solo

On May 20 2021, at 7:10 am, Christian Haider via Glass <glass at lists.gemtalksystems.com> wrote:
> Hi,
> I just tried to install GsDevKit on Ubuntu 20.04 LTS.
> The “createStone” step fails presumably because of an old and unavailable ssl library. The log file says:
> Package libssl1.0.0:i386 is not available, but is referred to by another package.
> This may mean that the package is missing, has been obsoleted, or
> is only available from another source
> E: Package 'libssl1.0.0:i386' has no installation candidate
> Any recommendation to get over this?
> Thanks,
> Christian
> P.S. since you probably want the whole log, I attached it (no secrets in there)
> _______________________________________________
> Glass mailing list
> Glass at lists.gemtalksystems.com
> https://lists.gemtalksystems.com/mailman/listinfo/glass

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.gemtalksystems.com/mailman/private/glass/attachments/20210526/c9e4ed35/attachment.htm>

More information about the Glass mailing list