[GemStone-Smalltalk] VSD on Mac ARM64

Kurt Kilpela kurt.kilpela at gemtalksystems.com
Mon May 22 10:36:32 PDT 2023


I am able to run VSD on an M1 MacBook Air. I did not use brew to install
XQuartz. Instead, I used the .pkg from xquartz.org.


On Mon, May 22, 2023 at 9:44 AM Johan Brichau via GemStone-Smalltalk <
gemstone-smalltalk at lists.gemtalksystems.com> wrote:

> Hi there,
> I tried to install the VSD application directly on my Mac ARM64 but I get
> an error starting it. It seems it does not find the X11 library. See below.
> I installed XQuartz with Homebrew using "brew install --cask xquartz”
> Anybody running VSD on the Mac ARM64?
> cheers
> Johan
> johanbrichau at JohansMacBookAir vsd5.6.0-arm64.Darwin % ./bin/vsdsh
> dyld[5437]: Library not loaded: /opt/local/lib/libX11.6.dylib
>   Referenced from: <F0174FC8-C455-3667-8F6B-F84372FCAB2B>
> /Applications/vsd5.6.0-arm64.Darwin/bin/vsdshDarwin
>   Reason: tried: '/opt/local/lib/libX11.6.dylib' (no such file),
> '/System/Volumes/Preboot/Cryptexes/OS/opt/local/lib/libX11.6.dylib' (no
> such file), '/opt/local/lib/libX11.6.dylib' (no such file),
> '/usr/lib/libX11.6.dylib' (no such file, not in dyld cache)
> _______________________________________________
> GemStone-Smalltalk mailing list
> GemStone-Smalltalk at lists.gemtalksystems.com
> https://lists.gemtalksystems.com/mailman/listinfo/gemstone-smalltalk
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gemtalksystems.com/mailman/archives/gemstone-smalltalk/attachments/20230522/bde20f32/attachment.htm>

More information about the GemStone-Smalltalk mailing list