[GemStone-Smalltalk] VSD on Mac ARM64

Johan Brichau johan at yesplan.be
Mon May 22 10:55:25 PDT 2023

Hi Kurt,

I tried that one as well now, but no success..

In which location is the libX11.6.dylib for you? Mine appears to be in /usr/local/lib/libX11.dylib but...
When I symlink that location to /opt/local/lib, I get the error that this is for x86 and not arm64.

So something seems to have gone wrong somewhere. Though XQuartz does report to be running arm64 and not x86…


> On 22 May 2023, at 19:36, Kurt Kilpela <kurt.kilpela at gemtalksystems.com> wrote:
> Johan,
> I am able to run VSD on an M1 MacBook Air. I did not use brew to install XQuartz. Instead, I used the .pkg from xquartz.org <http://xquartz.org/>.
> Kurt
> On Mon, May 22, 2023 at 9:44 AM Johan Brichau via GemStone-Smalltalk <gemstone-smalltalk at lists.gemtalksystems.com <mailto:gemstone-smalltalk at lists.gemtalksystems.com>> wrote:
>> Hi there,
>> I tried to install the VSD application directly on my Mac ARM64 but I get an error starting it. It seems it does not find the X11 library. See below.
>> I installed XQuartz with Homebrew using "brew install --cask xquartz”
>> Anybody running VSD on the Mac ARM64?
>> cheers
>> Johan
>> johanbrichau at JohansMacBookAir vsd5.6.0-arm64.Darwin % ./bin/vsdsh
>> dyld[5437]: Library not loaded: /opt/local/lib/libX11.6.dylib
>>   Referenced from: <F0174FC8-C455-3667-8F6B-F84372FCAB2B> /Applications/vsd5.6.0-arm64.Darwin/bin/vsdshDarwin
>>   Reason: tried: '/opt/local/lib/libX11.6.dylib' (no such file), '/System/Volumes/Preboot/Cryptexes/OS/opt/local/lib/libX11.6.dylib' (no such file), '/opt/local/lib/libX11.6.dylib' (no such file), '/usr/lib/libX11.6.dylib' (no such file, not in dyld cache)
>> _______________________________________________
>> GemStone-Smalltalk mailing list
>> GemStone-Smalltalk at lists.gemtalksystems.com <mailto:GemStone-Smalltalk at lists.gemtalksystems.com>
>> https://lists.gemtalksystems.com/mailman/listinfo/gemstone-smalltalk

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gemtalksystems.com/mailman/archives/gemstone-smalltalk/attachments/20230522/b6cf2488/attachment.htm>

More information about the GemStone-Smalltalk mailing list