[Glass] Seaside Cookies and Test Class WACookieTest

Dale Henrichs via Glass glass at lists.gemtalksystems.com
Mon Dec 8 12:54:19 PST 2014

Tim ... it has been a long time since I have worked with Seaside2.8 ... a
very long time .... I'm not even sure that I can easily bring up a system
with Seaside2.8 installed:)

I know that even for Seaside3.0 there was a fair amount of work that went
into getting the url encoding/decoding done right...

If you need help debugging this, perhaps a screen shot of the cookie test
browse screen (with missing chars) and the source code of the cookie test
would be place to start ...


On Mon, Dec 8, 2014 at 11:42 AM, Tim Krieg via Glass <
glass at lists.gemtalksystems.com> wrote:

> Hi,
> I'm running an older version of Glass (GEMSTONE: 2.3.0 with Seaside 2.8),
> and needed to read some cookies being populated from JavaScript Http
> requests results.  Some of the data being returned include the characters
> of
> $= and $?.  When I read the cookies in my Glass application, those
> characters are missing.
> I then tried adding cookies using the Glass provided class WACookieTest,
> and
> keyed in a string value that include the characters $= and $?.  Those
> characters are being excluded when the cookie value is rendered on the
> tests
> web page.
> Have others ran into this too?
> Thanks,
> Tim
> --
> View this message in context:
> http://forum.world.st/Seaside-Cookies-and-Test-Class-WACookieTest-tp4794827.html
> Sent from the GLASS mailing list archive at Nabble.com.
> _______________________________________________
> Glass mailing list
> Glass at lists.gemtalksystems.com
> http://lists.gemtalksystems.com/mailman/listinfo/glass
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gemtalksystems.com/mailman/private/glass/attachments/20141208/9542e3cc/attachment.html>

More information about the Glass mailing list