[Glass] gsDevKit / tode first time setup

Dale Henrichs via Glass glass at lists.gemtalksystems.com
Mon Oct 19 10:31:02 PDT 2015

On 10/18/2015 06:49 PM, Jon Paynter wrote:
> .. and reading the docs further, I see extra args for windows:
> |$GS_HOME/bin/installClient -c https 3.2.9 tode|
> But that should be:
> $GS_HOME/bin/installClient -c https tode 3.2.9
> Also, since the failed install leaves files behind, a  "git reset 
> --hard"  is needed to cleanup so the installer will work.
Okay I've updated the docs ($GS_HOME/bin/updateGsDevKit -g should pick 
up the the new docs)
> ... so after the installer finishes im confused what to do next.  The 
> docs say:
> To setup SSH port forwarding,
> |ssh -L 44834:hostNameOrIp user at example.com <mailto:user at example.com>|
> but what do I use for 'hostnameOrIp' ?
> I assume I run that cmd on my gemstone server.   The local IP of my VM 
> is
> So do I run something like this?
> ssh -L 56152: <then what goes here?>
> where "56152" is the netldi port number I got from running the 
> 'stones' cmd on my server.
> I tried, but it did not work:
> gemstone at ubuntu:~$ ssh -L 56152: user at host.com 
> <mailto:user at host.com>
> Bad local forwarding specification '56152:'

It sounds like we have a bit of work to do in this area for flow and 
correctness .... perhaps this doc[1] will get you going. The ssh 
statement for port forwarding should look like the following:

   ssh -l dhenrich -L 56152:<localhosOrIP>:56152

I should mention that the current session descriptions include a field 
for the netldi port:

TDSessionDescription {
     #name : 'xx_329',
     #stoneHost : 'foos.gemtalksystems.com',
     #stoneName : 'xx_329',
     #gemHost : 'foos.gemtalksystems.com',
     #netLDI : 'xx_329_ldi',
     #netLDIPort : '56152',
     #gemTask : 'gemnetobject',
     #userId : 'DataCurator',
     #password : 'swordfish',
     #osUserId : nil,
     #osPassword : nil,
     #dataDirectory : nil,
     #backupDirectory : 
     #snapshotDirectory : 
     #gemstoneVersion : '3.2.9',
     #gciLibraryName : nil,
     #adornmentColor : nil,
     #serverGitRoot : nil,
     #serverTodeRoot : '/export/foos1/users/dhenrich/dev/_home'

that you can set along with the name to ensure that your netldi will 
open on the same port every time ... if you use /etc/services, then you 
can leave the netLDIPort field empty.

> The client setup also says to copy some files from the server - but 
> the folder doesnt exist
> From the server installation, copy the server specificaion file to the 
> client. This file is
> |$GS_HOME/shared/tode/sys/local/client/descriptions/<myServerNodeName>|
> If you are using the same name as these examples, it will be named:
> |$GS_HOME/shared/tode/sys/local/client/descriptions/devKit_329|
> to the same path on the client node.
> but I cannot find a 'descriptions' folder anywhere under GsDevKit_home
This is a case, where I changed the structure used by the scripts 
without updating the docs ... the correct location is:


I'll update the docs.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gemtalksystems.com/mailman/private/glass/attachments/20151019/9ccb17ea/attachment.html>

More information about the Glass mailing list