[Glass] tode / pharo errors

Dale Henrichs via Glass glass at lists.gemtalksystems.com
Wed Oct 21 13:07:49 PDT 2015

On 10/21/2015 12:52 PM, Jon Paynter wrote:
> So after the server install finally finished, I followed instructions 
> to get tode client installed on my local PC here at the office.  but 
> when I tried to log in, I got a gci version mismatch error.  It seems 
> my attempt to install gemstone 3.2.8 only went partially through, but 
> everything used the old 3.1.x version that was already installed.
Well this supposition does not match with how the tode client works ... 
when you select a stone to connect to, the session description file for 
that stone is loaded and the gci file that is explicitly defined in the 
session description is used for the login. If no gci file is explicitly 
defined, then the gci file that includes the gemstone version in it's 
name is used ... if there is no matching gci file then you get a 
"external module not found"

Soooo, if you are getting a version mismatch error then the most likely 
explanation is that the session description file the stone on your 
client has a different version than the session description file on the 
remote server ...

I say "likely" because there are a number of possible alternate 
explanations --- without seeing the exact error message and seeing the 
session description files themselves (from client and server) I can only 
guess ...

> So I re-ran the installGemstone.sh script to install 3.2.8.  but when 
> I tried to start the stone, it gave an error about a wrong keyfile 
> because /opt/gemstone/product still pointed to 3.1.x.   but when I 
> changed the symlink to point to the 3.2.8 install, and then i could 
> not find seaside/system.conf.  So I copied the seaside folder to the 
> new install dir, but then gemstone crashed on startup.
The fact that /opt/gemstone/product is involved makes me wonder just 
what system you are using ... GsDevKit_home does not put anything into 
/opt/gemstone/product so the fact that /opt/gemstone/product is implied 
implies that you are not actually using GsDevKit_home or ????

If you are using the installGemStone.sh script, you are not using 
GsDevKit_home ... I'm not capable of helping if you are going to mix 
systems like this ... or you need to be very clear about what you are 
trying to do by running scripts that aren't part of GsDevKit_home ....


More information about the Glass mailing list