[Glass] Error installing gsDevKit on Ubuntu 14.04.3 LTS Desktop

Dale Henrichs via Glass glass at lists.gemtalksystems.com
Tue Sep 29 10:08:49 PDT 2015

On 09/29/2015 05:35 AM, Mariano Martinez Peck wrote:
> On Tue, Sep 29, 2015 at 9:28 AM, Alejandro Zuzek via Glass 
> <glass at lists.gemtalksystems.com 
> <mailto:glass at lists.gemtalksystems.com>> wrote:
>     Hi Dale,
>     I ran this script:
>     installServer devKit 3.2.1
>     I am not sure which branch of gsDevKit I am running, but these are
>     the command I run to download the project:
>     git clone https://github.com/GsDevKit/gsDevKitHome.git
>     cd gsDevKitHome
>     git checkout -b <your project branch name>
>     I don't have the full output available at the moment, but there
>     were no errors reported before the Pharo error mentioned in my
>     initial post. Would you need the full output? If so, should I at
>     least remove everything related to Pharo before re-running it (VM,
>     Sources and Image)?
> Two little comments (take them as from me, not from Dale). First, this 
> script and probably many others (like the old gemstone installation 
> script) are mostly "safe" in the sense of being able to be run 
> multiple times. The scripts check in every step of the existing of 
> certain files or settings in order to realize if such a step is needed 
> or has already been run.  As for example of the Pharo download, if you 
> check the script it does indeed checks if /pharo exists. So if there 
> is a chance the file was download but broken, then yes, I would remove 
> all it downloaded in order to make the script think you didn't do that 
> part and re run the script.
Mariano makes good points about being able to run the scripts without 
redoing work already done ...

Thanks for the additional details ... It looks like you are on the 
master branch and I am a bit mystified how you are getting this error. 
The `installServer` script first calls the installGemStone, then the 
createTodeImage[1] scripts. The createTodeImage script expects pharo to 
be installed during installGemStone. If the $GS_HOME/pharo/pharo-vm does 
not exist the installGemstone script calls installPharo[2].

The installPharo script then uses `wget` to get the pharo vm and the 
pharo images[3]:

   cd $GS_HOME/pharo
   wget -O- get.pharo.org/vmLatest | bash
   wget -O- get.pharo.org/30 | bash

All of the scripts use `set -e` and there are no `exit 0` calls without  
$GS_HOME/pharo/pharo-vm existing???

If you could run the above bash commands, and send me the results, 
perhaps we'll understand the mystery ...

OTOH, at this point in time, you should probably start useing 
GsDevKitHome on the dev branch by following these instructions[4] and do 
the "FOR EARLY ADOPTERS STEPS" ... the installPharo is a bit different 
and more importantly, the things you do and learn on the dev branch of 
GsDevKitHome will be closer to what will be present in GsDevKit_home 
when it is ready...


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gemtalksystems.com/mailman/private/glass/attachments/20150929/8278a41e/attachment-0001.html>

More information about the Glass mailing list