[Glass] Seaside - Installation - (1) problem with gemServer.ston script; (2) attaching via localhost

Mariano Martinez Peck via Glass glass at lists.gemtalksystems.com
Wed May 17 15:02:57 PDT 2017

Did you check the seaside gem logs? What happens with a netstat to 1750? Is
the port opened?

On May 17, 2017 4:52 PM, "Reg Krock via Glass" <
glass at lists.gemtalksystems.com> wrote:

I installed a new DevKit_33 (3.3.3)

I have installed Seaside in a server GsDevKit sever using the command:
     createStone -f devKit_33 3.3.3 | tee -a $GS_HOME/install.log

Then I executed the following to install Seside3
project load --loads=`#('Seaside-Welcome' 'Zinc' 'Development' 'Examples')`

I then tried to register the port:
home/seaside/gemServer --register=devKit_33 --type=zinc --port=1750

This failed with the message:

a CompileError occurred (error 1001),
undefined symbol  GemServer;
undefined symbol  ZnSeasideNewGemServer;
undefined symbol  ZnSeasideGemServer;
undefined symbol  GemServer;
undefined symbol  Dictionary;
undefined symbol  WARemoteDebuggingWalkbackErrorHandler;
undefined symbol  WAGemStoneProductionErrorHandler;
undefined symbol  WAInteractiveGemServerErrorHandler;
undefined symbol  WAAdmin;
undefined symbol  OrderedCollection;
undefined symbol  WADispatcher;
undefined symbol  TDManPage

and whenI then find that the following classes which are referenced in the
gemServer script are not loaded into the image.
FastCGISeasideGems, SwazooSeasideGemServer

?? Should  I have loaded another package or is there a problem with the
gemServer script ??

I then turned the two references into symbols and seaside server started.

tode 1 > ./gemServer --start=devKit_33

scriptLogEvent: 'performOnServer: devKit_33 :: $GS_HOME/shared/repos/
gsApplicationTools/bin/startGemServerGem devKit_33 "1750"
scriptLogEvent: 'performOnServer: SeasideMaintenanceVM ::
SeasideMaintenanceVM "''instance’'
sz:17 ZnSeasideNewGemServer]

I then tried to open the web page with no success:


?? It has been a long time since I started Seaside. What have I done wrong
here ??

Glass mailing list
Glass at lists.gemtalksystems.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gemtalksystems.com/mailman/private/glass/attachments/20170517/5d058a0f/attachment.html>

More information about the Glass mailing list