[Glass] Seaside - Installation - (1) problem with gemServer.ston script; (2) attaching via localhost

Reg Krock via Glass glass at lists.gemtalksystems.com
Wed May 17 13:52:49 PDT 2017

I installed a new DevKit_33 (3.3.3)

I have installed Seaside in a server GsDevKit sever using the command:
     createStone -f devKit_33 3.3.3 | tee -a $GS_HOME/install.log

Then I executed the following to install Seside3
	project load --loads=`#('Seaside-Welcome' 'Zinc' 'Development' 'Examples')` Seaside3

I then tried to register the port:
	home/seaside/gemServer --register=devKit_33 --type=zinc --port=1750

This failed with the message:

	a CompileError occurred (error 1001), 
		undefined symbol  GemServer; 
		undefined symbol  ZnSeasideNewGemServer; 
		undefined symbol  ZnSeasideGemServer; 
		undefined symbol  GemServer; 
		undefined symbol  Dictionary; 
		undefined symbol  WARemoteDebuggingWalkbackErrorHandler; 
		undefined symbol  WAGemStoneProductionErrorHandler; 
		undefined symbol  WAInteractiveGemServerErrorHandler; 
		undefined symbol  WAAdmin; 
		undefined symbol  OrderedCollection; 
		undefined symbol  WADispatcher; 
		undefined symbol  TDManPage

and whenI then find that the following classes which are referenced in the gemServer script are not loaded into the image.
	FastCGISeasideGems, SwazooSeasideGemServer

?? Should  I have loaded another package or is there a problem with the gemServer script ??

I then turned the two references into symbols and seaside server started.

	tode 1 > ./gemServer --start=devKit_33

	scriptLogEvent: 'performOnServer: devKit_33 :: $GS_HOME/shared/repos/gsApplicationTools/bin/startGemServerGem devKit_33 "1750" "/Users/regkrock/GsDevKit_home/server/stones/devKit_33"'
	scriptLogEvent: 'performOnServer: SeasideMaintenanceVM :: $GS_HOME/shared/repos/gsApplicationTools/bin/startGemServerGem SeasideMaintenanceVM "''instance’' "/Users/regkrock/GsDevKit_home/server/stones/devKit_33"'[260393985 sz:17 ZnSeasideNewGemServer] 

I then tried to open the web page with no success:


?? It has been a long time since I started Seaside. What have I done wrong here ??

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gemtalksystems.com/mailman/private/glass/attachments/20170517/06e9e98d/attachment.html>

More information about the Glass mailing list