[Glass] GsDevKit_home newbie questions

Mariano Martinez Peck via Glass glass at lists.gemtalksystems.com
Thu Nov 23 18:11:44 PST 2017

On Thu, Nov 23, 2017 at 7:58 PM, Bernhard Pieber via Glass <
glass at lists.gemtalksystems.com> wrote:

> Hi all,

Hi Bernhard, nice to see you here.

> I have installed GsDevKit_home on my Mac and managed to get the Seaside
> counter example working. Since I am a complete newbie to GsDevKit_home and
> tODE I have a ton of questions. ;-)
> First, is GsDevKit_home only meant for development purposes or also for
> use on a production server?
I am not the author, but I would say on production too for sure.  In fact,
its client vs server architecture makes it very nice for that approach. For
example, I install server side of GsDevKit_home on my servers and then
client side (with tODE client) in my developer / sysadmin machines.

> I could not get Seaside working using port 1750 as used in „Getting
> started with Seaside“. When I used port 7100 it worked.

No clue. I use Seaside in a different way (I do not use the Seaside project
from GsDevKit but instead I simply load BaselineOfSeaside and then I have
my custom scripts for the seaside gems).

> However, when I restarted my Mac, it stopped working. I guess I need to
> restart the stone.

Yes. On production, I made some init.d kind of script to start/stop/stat my
stones (I can share that script if you want), but some people don't like to
auto-start stones at OS boot.

> I tried „startStone -b seaside_34“.

That's correct.

> The stone started, however the following error is printed to stdout:
> waitstone[Error]: Network service !#dir:/Users/bernhard/
> Documents/GsDevKit_home/server/stones/seaside_34/logs#log:%N%P.log#server!seaside_34
> was not found.
> Network lookup failure; could not find server 'seaside_34' on host
> 'MacBookProRetina.local' because file not found:
> /opt/gemstone/locks/seaside_34..LCK;  service seaside_34 not found ;
> NetLDI service 'gs64ldi' not found on node 'localhost6' port 50377 :
> connect(7,::ffff:,port=50377) failed with errno=22,EINVAL,
> Invalid argument (programmer error)
> Is that something to be worried about?
I don't think so, I see same kind of printing too...which it would be nice
to be ignored. What is important is that you can see if netldi was started
correctly. COnsole should say something like:

startnetldi[Info]: GemStone server ' seaside_34_ldi' has been started,
process 20927

You can also look to `$GS_HOME/server/stones/seaside_34/logs/netldi.log`

Nevertheless...if you see the seaside gems alive, then it likely means that
netldi was working...

> While netldi, stoned and three gem processes are started, Seaside does not
> listen on port 7100. Why is that?

I really haven't used the Seaside scripts that come with GsDevKit's
Seaside. Maybe the Seaside adaptors were not started?

> Shouldn’t at least one of the gems serve Seaside requests?

By default, 3 gems are started (you can have thousands running) and so,
each should be able to serve Seaside requests.

> How can I start Seaside so that it survives restarting the stone?

In my case, I have the init.d which starts the stone and then calls bash
scripts to start seaside gems.

> One final question, I guess for production I’d need a web server like
> nginx or Apache in front of the stone, right?

On production, yes, I would, for sure. I use nginx where I can set HTTP2,
SSL cert, compression, caching, logging, try to prevent DoS attack, and
many features more.
And then from Seaside side you should use the FastCGI adaptors. Then at
nginx all you do is to redirect to a list of upstreams...

Hope this helps...

> Thanks for your terrific work!
> Bernhard
> _______________________________________________
> Glass mailing list
> Glass at lists.gemtalksystems.com
> http://lists.gemtalksystems.com/mailman/listinfo/glass

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gemtalksystems.com/mailman/private/glass/attachments/20171123/b9f807b8/attachment.html>

More information about the Glass mailing list