[Glass] GsDevKit Installation problems

Joachim Tuchel via Glass glass at lists.gemtalksystems.com
Tue Feb 10 05:57:00 PST 2015

We're just trying to get GsDevKit installed on a fresh Ubuntu 14.04 64bits VM.
Our fourth attempt is in progress, and so I£d like to take the time to comment
on the installetion process:
The instructions we`re following are these:
The following section is very unclear on what exactly you have to do:
2. Install GemStone/S and Pharo, build the tODE client image, create a stone,
start the stone, start the netldi, start the stamonitors, install tODE in stone
and launch the tODE client. The following creates a new stone named  tode  based
on  version 3.2.1 of GemStone/S
<http://gemtalksystems.com/index.php/news/version3-2/> :
We were wondering if we needed to exectute each of the steps (many of the
scripts in the gsDevKitHome path look as if they do exactly each of them. But we
decided to just type in what follows: installServer devKit 3.2.1
This runs for a while and stops because it cannot start Pharo. The message says:
pharo canot start because it cannot find some file. 
Since it was totally unclear to me if we should have done anything else than
just installServer, I tried starting Pharo by hand - with the same result.
A while later I thought I have the solution, which seemed blindingly obvious and
made me feel like an idiot: Pharo is a 32 bit executable, so we need the
ia32-libs, OF COURSE!!! Stupid me!!!
The only excuse for now is that I can always say that somebody must have
forgotten to write it into these instructions. 
IN the meantime, the fourth installation attempt has failed as well:

[Info] GemStone version information:
GemStone/S 64 Bit
3.2.1 Build: gss64_3_2_x_branch-33595
Thu Jun 5 14:37:10 2014
creating todeClient image

Fetched -> ConfigurationOfTodeClient-dkh.15 ---
filetree:///home/peter/Dokumente/gsDevKitHome/repository ---
Loaded -> ConfigurationOfTodeClient-dkh.15 ---
filetree:///home/peter/Dokumente/gsDevKitHome/repository ---
Loading 1.0.0 of ConfigurationOfTodeClient...
Fetched -> ConfigurationOfOSProcess-ThierryGoubier.37 ---
http://smalltalkhub.com/mc/Pharo/MetaRepoForPharo30/main/ ---
Loaded -> ConfigurationOfOSProcess-ThierryGoubier.37 ---
http://smalltalkhub.com/mc/Pharo/MetaRepoForPharo30/main/ ---
libssl.so.1.0.0: Kann die Shared-Object-Datei nicht öffnen: Datei oder
Verzeichnis nicht gefunden

...RETRY->BaselineOfTode'Errors in script loaded from
ZdcPluginMissing: SSL/TLS plugin initailization failed (VM plugin missing ? OS
libraries missing ?)
ZdcPluginSSLSession>>initialize in Block: [ :exception | ...
MethodContext(ContextPart)>>handleSignal: in Block: [ self exceptionHandlerBlock
cull: exception ]


At least, Pharo starts and writes a walkback, so we`re on the right track!

So I guess we`re still missing some libs for ssl on 32 bits. We need to take a
look at the Pharo website to find out what else we have to install before we try
a fifht time ;-)

My suggestion: Make the instructions a bit more clear, don`t mention 52 things
some script is going to do anyways, or at least not in the dummies section.

Then, make sure you add a short description of what is needed for Pharo to run.

Other than that: we look forward to seeing tode in action.








-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gemtalksystems.com/mailman/private/glass/attachments/20150210/c0c5d639/attachment.html>

More information about the Glass mailing list